phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

php version issues


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
roadhog
Board Member



Joined: 19 Nov 2008

Posts: 96
Location: Central Texas


flag
PostPosted: Thu Oct 29, 2020 1:24 am 
Post subject: php version issues

Hello everyone,

When I logged in , the message showed that my last login was in April of 2009. I reckon time flies when you're having fun, and my phpBB2 board has been running smoothly since May 24th of 2005. Until now. My host is upgrading the servers to php 7.3, so naturally that killed my board. I managed to talk a tech rep into rolling back the php version, and making sure it stayed there, until I could find a solution. Looks like my board is version 2.0.23. Back in those days, I was able to deal with the conversion files whenever necessary, even though I was never php-literate.

But I had a stroke about 3-1/2 years ago that left me a lot dumber. So when I read the discussions here about making the changes necessary to make phpBB2 compatible with php 7.3, I get depressed. I doubt that I could handle it. Ditto for upgrading to phpBB3. When I tried to do that, I managed to upload phpBB3 and begin the installation process, but when it came time to convert the database, naturally the phpBB3 board couldn't locate the database, because of the php version difference. It might be doable by converting in stages, but I'm not sure that I can do that. My board is also heavily modded. That's why I never converted in the first place. At the time, I didn't want to lose those mods. Now, the database contains so many years of valuable archives, that I can't afford to lose them, so I can't just set up a new board without converting. I never thought about converting the old board to run on php 7.3, until I read it here.

Is there any hope for me to either get my board converted. so that it's compatible with 7.3, or upgrade it to the current version of phpBB3? I no longer need the mods, but I don't want to lose all the old posts and member registrations in the database. Is there someone I could hire to make either conversion?

EDIT:

Never mind. I installed version 3.0.14. and the conversion worked like a treat. It doesn't appear to have lost anything in the conversion. If it's still not compatible with php version 7.3, I'll just go on up the ladder with the later versions of phpBB3.

All my best,

Wayne
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0232 seconds using 15 queries. (SQL 0.0019 Parse 0.0008 Other 0.0205)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo