phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

New user verification not being sent


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
SimonP
Board Member



Joined: 21 Jun 2018

Posts: 3



PostPosted: Thu Jun 21, 2018 2:04 am 
Post subject: New user verification not being sent

Hi, and thanks for this excellent resource.

I know it's old but I set my board up 11 years ago and it's been working perfectly so, "if it ain't broke" and all that...

I'm running phpBB 2.0.22 and all has been great for years but I recently noticed that we weren't getting any new users. Everything looks OK but no verification emails are being sent out and my host swears that nothing has changed at their end.

Being so long ago I can't for the life of me remember how I configured the email sending side of things and I can't even remember the terminology so I'm finding it hard to even ask the question!

Could you remind me where to check it and offer any ideas as to why it should stop working please? I'm feeling completely useless but need to get it working again.

Many thanks,
Simon.
Back to top
lumpy burgertushie
Board Member



Joined: 19 Nov 2008

Posts: 237


flag
PostPosted: Thu Jun 21, 2018 2:06 am 
Post subject: Re: New user verification not being sent

HI Simon,
please post a link to your board so we can see what is going on.

is email working on your board at all or just not for new user verification?


robert
Back to top
SimonP
Board Member



Joined: 21 Jun 2018

Posts: 3



PostPosted: Fri Jun 22, 2018 10:51 pm 
Post subject: Re: New user verification not being sent

Hi again Robert icon_smile.gif

The board is of an adult nature so probably best not to post it here but it seems not to be sending emails at all. I set up a test account the other day and watched for the verification email but nothing came. Also, as I said, we haven't had any new users for a while and that must be the reason, although I'm surprised no-one contacted me to ask about it.

I seem to remember that I had to tell it which program the host uses to send email but that was 11 years ago and I have a terrible memory at the best of times and haven't a clue what or where that was. Was that the case or does phpBB send the emails itself? Could it be that the host has somehow blocked it?

I'm completely stumped so any help or suggestions you can offer will be very gratefully received.

Cheers,
Simon.
Back to top
StarWolf3000
Board Member



Joined: 10 Jun 2010

Posts: 123
Location: Germany


flag
PostPosted: Sat Jun 23, 2018 6:06 am 
Post subject: Re: New user verification not being sent

phpBB either uses PHP's mail() method (if properly configured on the server, usually using sendmail as MTA) or an SMTP server, if configured. Using mail() is usually the most uncomplicated way, but if its disabled, then you have to use an SMTP server.

The catch with SMTP: In the last years a lot of the SMTP servers changed to only work over SSL/TLS and newer authentication mechanics (PLAIN, LOGIN, CRAM-MD5), which are only partially supported by phpBB's mailing function. Connecting using STARTTLS for example is not possible without changing the core file.
Back to top
Salvatos
Board Member



Joined: 19 Feb 2009

Posts: 439
Location: Qu├ębec


flag
PostPosted: Sat Jun 23, 2018 4:37 pm 
Post subject: Re: New user verification not being sent

If you have access to your server's error logs, or if you can temporarily turn on PHP's error notifications for your site, you might be able to catch something of interest when the e-mail should be sent but fails.
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 683
Location: Texas


flag
PostPosted: Tue Jun 26, 2018 4:14 am 
Post subject: Re: New user verification not being sent

Is the registration form working, but nothing is being sent? Or is the registration form not loading at all?

There was an upgrade to PHP that broke a couple of things, one of which is detailed here. But if that's your issue, your users would not even be able to load the registration page to fill out. That error broke this site a while back.

If the registration process seems to be working and it's only the email that's not going out, it's entirely possible that your domain has been black-listed and the emails are going out but simply not being delivered. Most hosts have a webmail feature. I would suggest that you log in to your account and send an email from your domain to another email address that you have and see if it arrives. If it never arrives, then it's not a phpBB problem but a more systematic issue with your email.

If you can send an email from your host without using phpBB and it works, then we have narrowed down the issue to something likely to be phpBB related, but that's what I would suggest you try next.

_________________
phpBBDoctor Blog
Back to top
vlad77
Board Member



Joined: 31 May 2015

Posts: 72


flag
PostPosted: Wed Jun 27, 2018 9:16 am 
Post subject: Re: New user verification not being sent

The simplest thing that can be done is to disable the check of mail when registering. Two options - automatic activation at the time of registration, or manual activation by the administrator.

If your domain was included in the blacklist, then this is the only quick solution.
Back to top
SimonP
Board Member



Joined: 21 Jun 2018

Posts: 3



PostPosted: Fri Jul 06, 2018 10:57 pm 
Post subject: Re: New user verification not being sent

Sorry for the slow reply. I hadn't thought to make sure that the email server was working as my email program was checking it without error so I assumed a phpBB fault but it turns out the server wasn't sending or receiving emails! It's not fixed yet but that's clearly the problem so thank you very much for your suggestions, I really appreciate it.

Simon.
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0257 seconds using 15 queries. (SQL 0.0026 Parse 0.0008 Other 0.0222)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo